What version(s) of TLS does Adyen support?

Use TLS 1.2

All merchant integrations with Adyen must use TLS 1.2.

TLS 1.0 mustn’t be used to protect payments data or payments pages after June 30, 2018.

The PCI Security Standards Council (PCI SSC) no longer accepts early TLS (TLS 1.0) as a secure communication protocol for transmitting payment card data, and we have therefore disabled older versions of TLS on our platform.

Note: Integrations such as Java 7 or .NET 4.0 don’t support TLS 1.2 using default configurations. Integrations using Java 6 and below, .NET 3.5 and below, Python 2.7.8 and below, Ruby 1.9.3 and below, OpenSSL 1.0.0 and below, will all be difficult or impossible to configure to use TLS 1.2, and significant migration effort may be required by the merchant. Additionally, shoppers using old browsers (IE8 and IE9 as well as Android versions 4.4 and below) that only support early TLS in combination with Hosted Payment Pages (HPP) and Client Side Encryption (CSE) won’t be able to connect to these services.

The integration security guide

Follow best practices to reduce security risks.

View integration security guide
The illustration of support agent wearing a headset.

Do you need additional help?

Contact our support team

Send us the details of your issue by adding images or screenshots.

Submit a request