驴C贸mo puedo activar el flujo de 3DS2 en la aplicaci贸n nativa para pagos?

En esta p谩gina se indican los requisitos para activar el flujo de 3DS2 en la aplicaci贸n nativa para los pagos en la app. Si tienes un flujo de redirecci贸n, en lugar del nativo, vuelve a comprobar que hayas incluido 鈥渟dkVersion鈥 correctamente en tu solicitud de API para la integraci贸n Checkout (/payments) o Classic (/authorize).

Si est谩s utilizando Checkout (/payments)

Nuestra plataforma espera que los merchants env铆en 鈥paymentMethod.threeDS2SdkVersion鈥 en la solicitud de API /payments, como se explic贸 aqu铆 para iOS y Android. Sigue los documentos de Adyen y lleva a cabo los dos pasos siguientes:

  1. Obt茅n threeSD2SdkVersion (iOS/Android).
  2. Env铆ala en la solicitud de pago a /payments.

Si est谩s utilizando Classic (/authorize)

Nuestra plataforma espera que los merchants env铆en 鈥threeDS2RequestData.sdkVersion鈥 en la solicitud de API /authorize como se explic贸 aqu铆 para iOS y Android. Sigue los documentos de Adyen y lleva a cabo los dos pasos siguientes:

  1. Obt茅n sdkVersion (iOS/Android).
  2. Env铆ala con la solicitud de pago a /authorize.

Comentarios/recomendaciones adicionales:

  1. Recomendamos especialmente el env铆o din谩mico de la versi贸n de SDK a nuestra plataforma desde el extremo del cliente o del component. Evita la codificaci贸n estricta o el env铆o de valores ficticios, ya que podr铆an interrumpir las transacciones en curso.聽
  2. Comprueba que tu versi贸n de SDK cumpla los requisitos siguientes:
    1. Integraci贸n Classic: iOS/Android v2.2.5
    2. Integraci贸n Checkout: Android Component v4.5.0 y iOS Component v4.10.2

Nuestra recomendaci贸n es la versi贸n m谩s actualizada del SDK de 3DS2. Notas de la versi贸n:

Si est谩s pasando correctamente la versi贸n de SDK en la solicitud de API, pero sigues teniendo problemas para activar el flujo de la aplicaci贸n nativa, consulta los pasos de soluci贸n de problemas siguientes:聽

M谩s informaci贸n

Encuentra m谩s informaci贸n sobre este tema.