Some of the new requirements are future-dated. when do I need to be compliant with them?

Future-dated new requirements become effective as of March 31, 2025. You're required to be compliant with these requirements if these requirements are in your PCI DSS scope.